Home » FAQ » BlackBerry » Why can't I use WhatsApp on BlackBerry OS 4.6 and 4.7?

Why can't I use WhatsApp on BlackBerry OS 4.6 and 4.7?

"Unfortunately, you won’t be able to use WhatsApp soon because your phone is running an old version of BlackBerry OS."

If you see this message, you are using a BlackBerry device running a version of the BlackBerry Operating System (OS) that WhatsApp no longer supports. Unfortunately, your phone cannot be updated to a supported version of the BlackBerry OS.

To continue to enjoy WhatsApp, we recommend you change to a supported phone. Please read this article to find out which devices are supported by WhatsApp.

We apologize for the inconvenience.

Cheers,
WhatsApp Support Team

FAQ